Error on Mac SSD but not Windows ?

TheLaird

New Member
Joined
Nov 20, 2023
Posts
14
Likes
41
Location
The Highlands of Scotland
Image Editing
No
Only had a Mac for a year and still have Windows PC for work, and the wife has hers for her work too.
I have a Crucial X8 SSD, formatted as ExFat (as I use Windows too).
Was working all OK, and then it was not. Tried various Mac repair type work, but to no avail.
Plugged it into Windows PC and it came up with an error. Run the repair and all was good. Plugged back into Mac and I can read and write to the SSD. However when I try to eject, ( and it is no longer showing on Mac Desktop) or shutting down Mac and then unplugging, when I try to use it on Mac again (or PC) it is not working and I need to do the PC repair item above.
I have other backups so not going to loose data but it is a 4TB drive and I want to keeping using it.

Mac First Aid seems to bomb out after/during checking file system hierarchy. It says cluster chain for a file has too few clusters for its size.

Should I bite the bullet and just re-format the SSD or is there something else I can do?

Many thanks for any help.
 
The lack of stability would be of major concern to me with regard to continued use. I just wouldn't feel comfortable about the data on there and its respective availability the next time I tried to use the drive. I'd reformat and see if the issues go away. If they persisted, I'd replace the drive.
 
So something has messed up the file system hierarchy. I had that once with a WD external drive, about 2 years ago. I reformatted the drive and it's been solid ever since, so I agree with Marvin and try that first.
 
I used to have both a PC and a Mac and used a portable drive formatted in ExFAT but it was always having problems, much like you described, so I stopped formatting in ExFat. It was just not stable for me.
 
Though I'm not at all familiar with Mac/Apple, it sounds as if the advice already given is solid.

I've had drives formatted for DOS and windows before, where the volume name and filenames
ended up something like [#*&$+!"*123%$&(#@^] and soforth. My only option was to fully delete
the MFT(master file table) and recreate, which resulted in surprisingly-stable HDDs afterwards.
This is a data-destructive method, which you indicate is not much of an issue.

I've also had good results with FAT32 and NTFS being accessible between Windows
and LINUX systems, with the 'nix being unable to write to one or the other.
But that's years ago now, so it may be different.

I'd suspect @davesrose may have some insight into this, as I believe he concurrently
uses Mac and Windows systems, and he's rather well-versed in the differences.

My only unrecoverable situation so far has been the 'click-of-death' HDD scenario,
which is fairly universal in total failure. It last affected a 2Tb drive of mine about 4 years ago,
and I've had redundancy in place ever since.
 
Back
Top Bottom